From: Darin Perusich 
Subject: [NMusers] nonmem under cygwin
Date: Thu, 21 Mar 2002 18:02:00 +0000


has anyone had any success get nonmem working in a cygwin environment?,
cygwin.com? i've successfully gotten nonmem to compile and the test
that comes with the source runs successfully but when i try to run other
jobs they never complete.

the machine is an amd 500 mhz, 128 Mb ram, win2k. the cygwin release is
version 1.3.10, gnu gcc, gnu binutils, etc.

any advice is greatly appreciated

-- 
Darin Perusich
Unix Systems Administrator
Cognigen Corp.
darinper@cognigencorp.com


*******

From: Bachman, William" 
Subject:[NMusers] nonmem under cygwin
Date: Thu, 21 Mar 2002
 
are you using the cygwin FORTRAN or are you trying to use C (via FtoC)?

*******


From: Darin Perusich 
Subject: Re: [NMusers] nonmem under cygwin
Date: Thu, 21 Mar 2002 20:20:23 +0000

i'm using the cygwin fortran compiler g77, which is part of the gnu gcc
(GNU Compiler Collection).


*******

From: "Tensfeldt, Thomas G" 
Subject: RE: [NMusers] nonmem under cygwin
Date: Thu, 21 Mar 2002 16:16:38 -0500

Darin,

I have a very nice environment under cygwin using custom perl scripts that
run nonmem using the g77 compiler. The current release I'm using is the
latest one, 1.3.10. The results of jobs running in that environment compare
well with jobs that I run in other unix based environments, i.e. Dec fortran
f77 under Dec Unix. I'm not sure why you're having problems. Perhaps you
could show us how you're executing the jobs?

Tom Tensfeldt
Clinical PK/PD Group
Pfizer Global Research & Development
Groton, CT 06340


*******


From: Darin Perusich 
Subject: Re: [NMusers] nonmem under cygwin
Date: Mon, 25 Mar 2002 13:54:53 +0000
  
  
hi tom,

i'm also looking to do a comparison between the cygwin environment and
our unix systems. i was using a custom perl script to execute the jobs
but they're not working as expected under cygwin so i'm using the nmfe5
script that comes with the nonmem source to execute nonmem. 

the only reason i can think of for the jobs not completing, at this
point is that i haven't installed some package that it needs. this is
what i've installed so far, cygwin 1.3.10, bzip, gettext, libintl1,
libintl, libtool, GCC, make, tcsh, vim, win32api.


*******